1.调试需要本地搭建网站集成环境(如IIS、Apache,Nginx),单纯地本地打开文件不能看到兼容效果。

2.如果你发现已经引用了respond.js和Bootstrap,仍无效果,请查看你的Bootstrap是否使用了CDN文件

3.本文主要针对Bootstrap3版本,如果你是Bootstrap2 ,请搜索 BSIE ,还可以兼容IE6浏览器.

4.Bootstrap3 需要Html5文档声明。

实例代码

<!DOCTYPE html>
<html lang="en">
    <head>
        <meta charset="utf-8">
        <meta http-equiv="X-UA-Compatible" content="IE=edge">
        <meta name="viewport" content="width=device-width, initial-scale=1">
        <title>Bootstrap 3兼容IE8浏览器</title>

        <!-- Bootstrap CSS -->
        <!-- 这里不能使用cdn,请自行下载 bootstrap 修改路径 -->
        <link rel="stylesheet" href="bootstrap-3.3.7-dist/css/bootstrap.min.css" rel="stylesheet">

        <!--[if lt IE 9]>
            <script src="http://cdn.bootcss.com/html5shiv/3.7.3/html5shiv.js"></script>
            <script src="http://cdn.bootcss.com/respond.js/1.4.2/respond.min.js"></script>
        <![endif]-->

    </head>
    <body>


        <!-- 调用 jQuery -->
        <script src="http://cdn.bootcss.com/jquery/1.11.1/jquery.js"></script>
        <!-- 调用 Bootstrap JavaScript -->
        <script src="http://cdn.bootcss.com/bootstrap/3.3.7/js/bootstrap.min.js"></script>

    </body>
</html>